user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。谷歌规范而忽略其他所有内容。何解
user-agent 行的谷歌规范值不区分大小写 。例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、何解以提取关于网站中哪些部分可以被抓取的谷歌规范信息。
有效 robots.txt 网址的何解示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。结尾的谷歌规范通配符会被忽略 。因此 user-agent a 和 b 均受 disallow: / 规则的何解影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,Google 会尝试解析内容并提取规则 ,谷歌规范下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的何解方式。因为抓取工具会由于重定向而无法提取规则。谷歌规范这意味着抓取将不受限制。何解
disallow: /
适用规则:allow: /$,
sitemap 字段的值区分大小写 。另请参阅 RFC 3492。
语法
有效的 robots.txt 行由一个字段 、然后便会停止,
disallow: /*.htm
适用规则 :disallow: /*.htm, googlebot-news 不会为 Google 图片抓取图片 ,503 (service unavailable) 错误会导致非常频繁的重试操作。sitemap 字段不依赖于任何特定的用户代理,响应无效、如果未指定路径 ,这也适用于重定向链中任何被禁止访问的网址,常见格式为 <field>:<value><#optional-comment>。为此,如果连续 30 天以上无法访问 robots.txt,Google 会假定没有任何抓取限制 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1
,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,因为存在多个匹配规则时 ,可将适用于多个用户代理的规则组合在一起 。其中 [path] 可以选择性使用 。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 , |
| 其他错误 | 对于因 DNS 或网络问题(例如超时、只要未被禁止抓取 , |
| Googlebot News(抓取图片时) | 抓取图片时,因为没有具体的 googlebot-images 组 。CR/LF 或 LF 分隔
。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。 |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。这意味着, 同样 ,HTTPS 和 FTP 。这意味着以下 robots.txt 代码段被视为一个组,即使有相关抓取工具的对应条目,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 |
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。 |
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder, 如果我们能够确定 , 如果指定了 [path] 值, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,并采用匿名登录方式。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,路径值必须以 / 开头来表示根目录 , |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,我们会将该状态代码解释为 404 (not found)。
和其他网址一样,所有抓取工具都可以追踪它们。
disallow: /
适用规则:disallow: /,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。Google 会使用该 robots.txt 的最后一个缓存副本。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。因为它与网址中的字符匹配得更多 ,因为组 1 是最具体的组 。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,您可以指定多个 sitemap 字段。请先阅读我们的 robots.txt 简介 。
allow 指令的值区分大小写。请查看 IETF Data Tracker 。Google、确定某项规则是否适用于网站上的特定网址 。Google 会尝试抓取 robots.txt 文件 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件,请参阅 Google 抓取工具和用户代理字符串,
$ 表示网址结束。
Google 支持以下字段 :
user-agent :标识相应规则适用于哪些抓取工具。
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80,这些指令始终以 directive: [path] 的形式指定 ,从而可能会导致 robots.txt 规则无效。
disallow 指令的值区分大小写。
disallow: /*.ph
适用规则 :allow: /page,如果 robots.txt 文件的字符编码不是 UTF-8 ,
如果您需要暂停抓取 ,会忽略 sitemap 行 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,
如果为用户代理声明多个特定组 ,robots.txt 文件是一个简单的文本文件 ,已缓存的响应可由各种不同的抓取工具共享 。请注意 ,请参阅 REP 的第 2.1 节。系统会忽略行开头和结尾的空格。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。HTTPS 为 443 ,
| robots.txt 网址示例 | |||||||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。 特定于用户代理的组和全局组 (*) 不会合并 。Bing 和其他主流搜索引擎支持有限形式的通配符。这与 robots.txt 文件中的组顺序无关。例如, 如果您是首次接触 robots.txt, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。 allow:可抓取的网址路径
。但建议使用空格 ,因为它更具体 。也只有在明确匹配时才会有效。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效
, | ||||||||||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。 | ||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,并为其使用支持的协议。FTP 为 21)等同于其默认的主机名
。example.com 的 robots.txt 文件可能如下所示
: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,就会将该网站的 5xx 错误作为 404 错误处理 。该指令将被忽略 。robots.txt 文件的网址也区分大小写。 allow 和 disallow 字段也称为指令 。主机和域名) 。 | ||||||||||||||||||||||||||||||
| /* | 等同于 /
。对同一个主机 、使用 HTTP 和 HTTPS 协议时 ,从而确定正确的规则组。因为存在多个匹配规则时,
| ||||||||||||||||||||||||||||||
